Memisahkan Traffic Game, Youtube dan Browsing dengan Mikrotik

Sedati – Kali aku akan mencoba berbagi tutorial untuk memisahkan traffic atau jalur game, youtube dan browsing dengan mikrotik. Cara ini aku lakukan karena untuk membagi bandwidth yang terbatas, sehingga perlu manajemen bandwidth yang tepat agar perangkat-perangkat yang terhubung ke WiFi tidak mengalami masalah pada saat koneksi, baik untuk game, youtube maupun browsing.

Kalau aku melihat jumlah user yang terhubung ke jarigan WiFi tidak banyak hanya sekitar 8 sampai dengan 10 perangkat, tentu ini akan menggangu jika semua bandwidth diperebutkan seperti hukum rimba, siapa yang kuat maka akan mendapatkan bandwidth yang banyak.

Tipologi Jaringan

Tipologi jaringan yang ada di rumah seperti gambar diatas. Disini peran mikrotik-lah yang melakukan handle atau pembagian bandiwidth atau manajemen user agar koneksi internet tetap lancar pada semua perangkat.

Asumsi Jaringan

  1. Aku mengasumsikan tipologi jaringan sudah seperti gambar diatas, dan mikrotik sudah berjalan, aku tidak menyertakan bagaimana setting dasar mikrotik agar terhubung di Internet. Jika mikrotik sudah terhubung dengan internet dan user yang dikelolanya sudah dapat terhubung dengan internet maka bisa diikuti langkah-langkah berikut.
  2. Kelas IP untuk jaringan lokal yang aku gunakan adalah 192.168.10.0/24, jika teman-teman menggunakan kelas IP lainnya maka nanti discript tinggal menyesuaikan.
  3. Jalur yang dipisahkan adalah game, youtube dan browsing. Aku mengasumsikan bahwa port untuk game adalah selain port 80,443,8080,53,21-25,223,8291 atau port 80,443,8080,53,21-25,223,8291 adalah port yang digunakan untuk browsing, selain itu dianggap port game. Kenapa ada port 223 dan 8291? karena port 223 adalah port untuk SSH yang semula 22 saya rubah ke 223, dan port 8291 adalah port Winbox

Langkah-langkah

Ada beberapa langkah yang harus dilakukan pertama adalah buka winbox dan console, kita akan bermain dengan console saja ya.

  • Mangle untuk Game

Sebelumnya buat di address list, copykan script berikut:

/ip firewall address-list
add address=192.168.10.0/24 list=Privat_IP4

Tujuan dari script diatas adalah Private IP yang digunakan adalah 192.168.10.0-192.168.10.255. Setelah itu kita buat script untuk menangkap IP games yang diakases, caranya menggunakan Filter Raw, berikut adalah scriptnya.

/ip firewall raw
add action=add-dst-to-address-list address-list=virus address-list-timeout=1d \
chain=prerouting comment=Virus dst-address-list=!Privat_IP4 dst-port=\
67,135-139,445,520,3389,20004,7533,5678,20561 protocol=udp \
src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Vainglory dst-address-list=!Privat_IP4 dst-port=\
7000-8020 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Vainglory content=.superevil.net \
dst-address-list=!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="Mobile Legends" dst-address-list=!Privat_IP4 \
dst-port=30000-30150 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="Mobile Legends" dst-address-list=!Privat_IP4 \
dst-port=44590-44610 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="PUBG Mobile" dst-address-list=!Privat_IP4 \
dst-port=10012-17500 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="PUBG Mobile" dst-address-list=!Privat_IP4 \
dst-port=7086-7995,12070-12460,41182-42474 protocol=udp src-address-list=\
Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="PUBG Mobile" content=tencentgames.helpshift.com \
dst-address-list=!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Garena content=.garenanow.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=FM19 content=.amazonaws.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=FM19 content=fm19 dst-address-list=!Privat_IP4 \
src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Roblox content=roblox dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Roblox content=roblox.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Roblox dst-address-list=!Privat_IP4 dst-port=\
56849-57729,60275-64632 protocol=udp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Minecraft content=mojang dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Minecraft content=.mojang.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Minecraft content=unity dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Amazonaws content=.amazonaws.com \
dst-address-list=!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Gameloft content=.gameloft.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Xboxlive content=.xboxlive.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Friv.COM content=.friv.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="Asphalt 9" dst-address-list=!Privat_IP4 \
dst-port=420,36323,45125,46339,43393 protocol=tcp src-address-list=\
Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="Asphalt 9" dst-address-list=!Privat_IP4 \
dst-port=3544 protocol=udp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=Gameloop content=.qq.com dst-address-list=\
!Privat_IP4 src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="Free Fire" dst-address-list=!Privat_IP4 \
dst-port=10000-10007 protocol=udp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=DOTA2 dst-address-list=!Privat_IP4 dst-port=\
27000-28998 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=DOTA2 dst-address-list=!Privat_IP4 dst-port=\
27000-28998 protocol=udp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=PALADINS dst-address-list=!Privat_IP4 dst-port=\
9000-9999 protocol=udp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment=PALADINS dst-address-list=!Privat_IP4 dst-port=\
9000-9999 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="FIFA ONLINE" dst-address-list=!Privat_IP4 \
dst-port=7770-7790 protocol=tcp src-address-list=Privat_IP4
add action=add-dst-to-address-list address-list=games address-list-timeout=1d \
chain=prerouting comment="FIFA ONLINE" dst-address-list=!Privat_IP4 \
dst-port=16300-16350 protocol=udp src-address-list=Privat_IP4

Tujuan dari script diatas adalah menangkap IP games yang diakases dan disimpan di address list, setelah itu baru kita membuat mangle untuk Games.

/ip firewall mangle
add action=mark-connection chain=forward comment="Mark Games" dst-port=\
!80,443,8080,53,21-25,223,8291 new-connection-mark=games passthrough=yes \
protocol=tcp src-address=192.168.10.0/24
add action=mark-connection chain=forward dst-port=\
!80,443,8080,53,21-25,223,8291 new-connection-mark=games passthrough=yes \
protocol=udp src-address=192.168.10.0/24
add action=mark-connection chain=forward dst-address-list=games \
new-connection-mark=games passthrough=yes src-address=192.168.10.0/24
add action=mark-packet chain=postrouting comment="Packet Games" \
connection-mark=games new-packet-mark=packet-games passthrough=no

Silahkan copy script diatas dan paste-kan ke console lalu tekan enter, silahkan lihat pada menu IP > Firewall > Mangle maka akan ada tambahan untuk mark games dan packet games. Untuk mengecek apakah mangle tersebut berjalan, silahkan main games maka akan muncul angka-angka pada kolom Bytes dan Packets

  • Mangle untuk youtube

Untuk membuat mangle youtube, maka sebelumnya harus membuat layer7 dengan script sebagai berikut

/ip firewall layer7-protocol
add name=youtube regexp="^.+(.youtube.com|youtube.com|.googlevideo.com|googlev\
ideo.com|cdn.dailymotion.com|metacafe.com|mccont.com|.vidio.com|.static6.c\
om|vidio.com|.ytimg.com|.facebook.com|.fbcdn.net|tvindo.stream|.tvindo.str\
eam|master.m3u8).*\$"

Copy dan paste kan script diatas ke console dan periksa apakah pada IP > Firewall > Layer7 ada tambahan youtube, jika sudah ada berarti sudah berhasil. Pada layer7 ini bukan hanya youtube saja, tetapi yang berbau streaming seperti di FB, MMC, vidio.com dll saya masukan daftar youtube.

Setelah membuat layer7, selanjutnya adalah melakukan identifikasi ip-ip yang digunakan oleh youtube dll untuk dimasukan dalam address list. Scriptnya adalah sebagai berikut:

/ip firewall filter
add action=add-dst-to-address-list address-list=youtube address-list-timeout=\
4d chain=forward comment="Add List Address youtube" layer7-protocol=\
youtube

Script diatas bertujuan jika ada user yang mengakses youtube, maka IP youtube selama 4 hari akan ditangkap dalam address list. IP tersebut juga akan dilakukan dasar untuk melakukan mangle. Biar joss saja sih.

Selanjutnya adalah membuat mangle khusus youtube, scriptya adalah sebagai berikut:

/ip firewall mangle
add action=mark-connection chain=forward comment="Mark Youtube" \
dst-address-list=youtube new-connection-mark=youtube passthrough=yes \
src-address=192.168.10.0/24
add action=mark-connection chain=forward layer7-protocol=youtube \
new-connection-mark=youtube passthrough=yes src-address=192.168.10.0/24
add action=mark-packet chain=postrouting comment="Packet Youtube" \
connection-mark=youtube new-packet-mark=packet-youtube passthrough=no

Copy dan pastekan script diatas maka akan muncul mangle untuk mark youtube dan packet youtube.

  • Mangle untuk browsing

Membuat mangle untuk browsing sangatlah mudah yaitu pada connection-mark diisi no-mark artinya semua paket yang belum ditandai baik pada packet games maupun youtube akan dimasukan dalam packet browsing. Scriptnya adalah sebagai berikut:

/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark \
new-connection-mark=browsing passthrough=yes src-address=192.168.10.0/24
add action=mark-packet chain=postrouting comment="Packet Browsing" \
connection-mark=browsing new-packet-mark=packet-browsing passthrough=no

Jika langkah-langkah diatas sudah dilaksanakan dengan baik maka, semua paket games, youtube dan browsing sudah ditandai, tinggal kita membuat Queue untuk membuat pembatasan untuk setiap usernya, contoh sederhanya sebagai berikut.

/queue simple
add limit-at=10M/10M max-limit=10M/10M name=TOTAL target=bridge_ALL
target=192.168.10.0/24
add limit-at=2M/2M max-limit=2M/2M name=packet-youtube packet-marks=\
packet-youtube parent=TOTAL target=192.168.10.0/24
add limit-at=5M/5M max-limit=5M/5M name=packet-browsing packet-marks=\
packet-browsing parent=TOTAL target=192.168.10.0/24
add limit-at=3M/3M max-limit=3M/3M name=packer-games packet-marks=\
packet-lainnya parent=TOTAL target=192.168.10.0/24

Dari Queue diatas terlihat bahwa packet games hanya saya batasi maksimal 3 M untuk semua IP yang bermain games, begitu juga dengan packet youtube saya batasi 2 M untuk semua IP yang akses, sementara packet browsing 5 M.

Hasil Akhir

Dari cara diatas akumelihat, mengamati dan merasakan bahwa bermain game tidak menjadi masalah seperti Rolox, Minecraft dan game lainnya, sementara yang sedang ber-youtube juga tidak pernah lag apalagi yang browsing. Tampilan di Mangle adalah seperti berikut.

Semoga bisa membantu dan mencerahkan, jika ada pertanyaan bisa ditulis pada kolom komentar.

avatar
8 Comment threads
8 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
9 Comment authors
BowieprastyoRatnoHasanesn Recent comment authors
  Subscribe  
newest oldest
Notify of
andri satriana
Guest
andri satriana

saya coba ya gan

Bogani
Guest
Bogani

Kelas IP untuk jaringan lokal…, maksudnya IP yg mengara ke client…?

Bogani
Guest
Bogani

Kelas IP untuk jaringan lokal…., IP yg mengara ke client…????

iwan
Guest
iwan

salam kenal dari cicurug sukabumi . mhn ijin skrip nya sy coba ya mas, dan maaf mau tanya mas kalau skrip yg terakhir itu apa harus di sesuaikan dgn yg ada di user propil hotspot ga.? trimakasih sebelum nya

Hasan
Guest
Hasan

Ijin Coba dan share gan..(salam sukses selalu…

Ratno
Guest
Ratno

Apakah saat ada pelanggan mendownload akan masuk ke packet browsing ? Berarti di Simple queue nya akan jebol dong ?

prastyo
Guest
prastyo

packet marknya kok paket kantor y gan kok gk ke packet browsing dan packet games kok ke packet-lainnya

Bowie
Guest
Bowie

Saya menggunakan banyak IP pada satu interface. Bagaimana cara menerapkan script di atas?